Skip to main content
← All vulnerabilities
CVE-2024-9870

Unintended Proxy or Intermediary ('Confused Deputy') in GitLab

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 17.6.5, 17.7.4, 17.8.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An external service interaction vulnerability in GitLab EE affecting all versions from 15.11 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2 allows an attacker to send requests from the GitLab server to unintended services.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 15.11 · fixed in 17.6.5; From 17.7 · fixed in 17.7.4; From 17.8 · fixed in 17.8.2

References 2

gitlab.com

hackerone.com