CVE-2024-9313GO-2024-3181GHSA-X5Q3-C8RM-W787
Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform an
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.3.5, 0.0.0-20240930103526-63e527496b01
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- authd
fixed in 0.3.5
- github.com/ubuntu/authdGo
fixed in 0.3.5
- github.com/ubuntu/authdGo
fixed in 0.0.0-20240930103526-63e527496b01
- github.com/ubuntu/authdGo
From 0.1.0 · fixed in 0.3.5