Skip to main content
← All vulnerabilities
CVE-2024-8912

HTTP Request Smuggling in Looker

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 23.12.123, 23.18.117, 24.0.92, 24.6.77, 24.8.66, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An HTTP Request Smuggling vulnerability in Looker allowed an unauthorized attacker to capture HTTP responses destined for legitimate users. There are two Looker versions that are hosted by Looker: • Looker (Google Cloud core) was found to be vulnerable. This issue has already been mitigated and our investigation has found no signs of exploitation. • Looker (original) was not vulnerable to this issue. Customer-hosted Looker instances were found to be vulnerable and must be upgraded. This vulnerability has been patched in all supported versions of customer-hosted Looker, which are available on the Looker download page https://download.looker.com/ . For Looker customer-hosted instances, please update to the latest supported version of Looker as soon as possible. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page: • 23.12 -> 23.12.123+ • 23.18 -> 23.18.117+ • 24.0 -> 24.0.92+ • 24.6 -> 24.6.77+ • 24.8 -> 24.8.66+ • 24.10 -> 24.10.78+ • 24.12 -> 24.12.56+ • 24.14 -> 24.14.37+

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Google Looker

    From 23.12.0 · fixed in 23.12.123; From 23.18.0 · fixed in 23.18.117; From 24.0.0 · fixed in 24.0.92; From 24.6.0 · fixed in 24.6.77; From 24.8.0 · fixed in 24.8.66; From 24.10.0 · fixed in 24.10.78; From 24.12.0 · fixed in 24.12.56; From 24.14.0 · fixed in 24.14.37

  • Google Looker

    From 23.6 · through 24.14

References 1

cloud.google.com