Skip to main content
← All vulnerabilities
CVE-2024-8462GO-2024-3118GHSA-G6Q4-W3J3-JFC4

Windmill HTTP Request users.rs excessive authentication

Published
Last modified
published
Not listed in CISA KEV
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was found in Windmill 1.380.0. It has been classified as problematic. Affected is an unknown function of the file backend/windmill-api/src/users.rs of the component HTTP Request Handler. The manipulation leads to improper restriction of excessive authentication attempts. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.390.1 is able to address this issue. The patch is identified as acfe7786152f036f2476f93ab5536571514fa9e3. It is recommended to upgrade the affected component.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a Windmill

    1.380.0

  • github.com/windmill-labs/windmillGo

    All versions

  • github.com/windmill-labs/windmillGo

    through 1.61.1

References 5

vuldb.com

GitHub · windmill-labs/windmill