Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 22.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
An authentication bypass vulnerability has been identified in Pulpcore when deployed with Gunicorn versions prior to 22.0, due to the puppet-pulpcore configuration. This issue arises from Apache's mod_proxy not properly unsetting headers because of restrictions on underscores in HTTP headers, allowing authentication through a malformed header. This flaw impacts all active Satellite deployments (6.13, 6.14 and 6.15) which are using Pulpcore version 3.0+ and could potentially enable unauthorized users to gain administrative access.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- pulpcore
fixed in 22.0
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- foreman-installer
Version range not reported
- pulpcore-selinux
Version range not reported
- python-pulpcore
Version range not reported
- python-pulpcore-client
Version range not reported